Dos vulnerabilidades críticas afectan a los «thin client» Dell Wyse

Catagoladas como CVE-2020-29491 y CVE-2020-29492, y con una puntuación CVSS de 10 sobre 10, estas vulnerabilidades residen en la falta de autenticación de las sesiones FTP y permitirían a un actor malicioso en la misma red leer y modificar ficheros de configuración para llevar a cabo diversos ataques.

Un equipo de investigadores de la empresa CyberMDX ha desvelado dos vulnerabilidades críticas en los dispositivos Dell Wyse Thin Client que podrían permitir a atacantes la ejecución de código malicioso así como el acceso a ficheros arbitrarios en los dispositivos afectados.

  • La vulnerabilidad identificada como CVE-2020-29491 permite a un atacante remoto acceder al sistema afectado debido a una configuración no segura por defecto. El atacante, sin estar autenticado, podría tener acceso a información sensible almacenada en ficheros INI de configuración y comprometer los «thin client» afectados.
  • La otra vulnerabilidad, con el código CVE-2020-29492, aprovecharía la configuración no segura por defecto para permitir al atacante remoto, sin estar autenticado, modificar la configuración en ficheros INI de cualquier «thin client» objetivo.

Leer o alterar estos parámetros en los ficheros INI abre la puerta a una gran variedad de escenarios de ataque. Configurar y habilitar VNC para control remoto, filtrar credenciales de escritorio remoto o manipular resultados de DNS serían tan solo algunos de los escenarios preocupantes.

Ambos fallos fueron reportados a Dell en junio de 2020, y afectarían a todos los dispositivos que ejecuten ThinOS 8.6 e inferior. Desde Dell ya han publicado una actualización para subsanarlos. Dada la relativa facilidad de explotación, se recomienda que se apliquen los parches tan pronto como sea posible para mitigar el potencial impacto.

Modelos afectados por CVE-2020-29491 y CVE-2020-29492. Fuente

La empresa responsable del descubrimiento, CyberMDX, también recomienda actualizar los clientes compatibles a ThinOS 9, que elimina la configuración a través de los ficheros INI. En caso de que no se pueda realizar esta actualización, recomiendan deshabilitar el uso de FTP y utilizar en su lugar un servidor HTTPS o Wyse Management Suite.

Más información:
Two Critical Flaws — CVSS Score 10 — Affect Dell Wyse Thin Client Devices https://thehackernews.com/2020/12/two-critical-flaws-cvss-score-10-affect.html
Multiple vulnerabilities in Dell Wyse ThinOS https://www.cybersecurity-help.cz/vdb/SB2020122132
Dell Wyse Thin Client scores two perfect 10 security flaws https://www.theregister.com/2020/12/21/dell_wyse_thin_client_scores/

Comparte en tus redes: