Múltiples dispositivos de la marca Netgear son susceptibles a ataques basados en desbordamiento de pila.

Múltiples dispositivos Netgear contienen un servidor web para ofrecer la administración de estos a través de una interfaz web. El código contenido en el proceso ‘httpd’ encargado de servir el contenido no valida correctamente el tamaño de la cabecera proporcionada por el manejador ‘update_check.cgi’.

El desbordamiento se produce al copiar la cabecera de tamaño fijo en la pila. Esto permite la ejecución remota del código mediante el desbordamiento del memoria intermedia. Esta vulnerabilidad es agravada por una serie de problemas en los dispositivos de Netgear:

● El proceso httpd corre con privilegios de root.

● Los dispositivos de Netgear no utilizan generalmente protecciones para evitar la explotación de los stack buffer overflow, como stack canary.

● No requiere ningún tipo de autenticación para alcanzar el código vulnerable.

● La vulnerabilidad se produce antes de que se produzca la comprobación del token CSRF.

● Puedes obtener el fingerprinting del dispositivo objetivo accediendo a la página /currentsetting.htm de un dispositivo afectado.

Netgear se ha puesto manos a la obra y ha proporcionado​ ​actualizaciones para varios dispositivos vulnerables​. Hay que tener en cuenta que Netgear no avisa cuando los dispositivos han alcanzado un estado de fin de vida, por lo que puede ser difícil determinar si un dispositivo vulnerable puede recibir una actualización en un futuro.

Desde Hispasec recomendamos tener en cuenta la duración del soporte del proveedor en las decisiones de compra.

Referencias:

https://www.zerodayinitiative.com/advisories/ZDI-20-712/
https://blog.grimm-co.com/2020/06/soho-device-exploitation.html
https://github.com/grimm-co/NotQuite0DayFriday/tree/master/2020.06.15-netgear

Comparte en tus redes: