‘VMware vRealize Business for Cloud’ afectado por una vulnerabilidad de ejecución de código remota (RCE)

Durante el año 2021, han sido detectadas varias vulnerabilidades críticas sobre los productos VMware. En el mes de febrero, publicamos una noticia en Una al Día referente a un fallo de seguridad crítico sobre el software de administración VMware vCenter Server. Del mismo modo, durante el mes de abril, publicamos otra noticia sobre una vulnerabilidad crítica que afectaba a los productos VMware Carbon Black. De nuevo, VMware ha publicado un parche de seguridad, VMSA-2021-0007, el cual corrige una vulnerabilidad crítica, esta vez sobre los productos ‘VMware vRealize Business for Cloud‘ en la versión 7.6.0.

Fuente: Imagen extraída del blog itcloud.es

El investigador de seguridad Egor Dimitrenko, perteneciente a la compañía de seguridad Positive Technologies (con sede principal en Moscú), reportó el fallo de seguridad asignado con el código CVE-2021-21984 y una puntuación CVSSv3 de 9.8.

La vulnerabilidad puede ser explotada usando la interfaz API VAMI (vCenter Server Appliance Management Interface), en la cual existen determinados ‘endpoints’ accesibles de forma no autorizada. De este modo, aprovechando el acceso no autorizado, un atacante podría obtener ejecución de código remoto (RCE, del inglés, Remote Code Execution).

¿Cómo aplicar el parche de seguridad?

Desde BleepingComputer.com, explican como aplicar el parche de seguridad sobre los dispositivos virtuales configurados en la versión de vRealize Business for Cloud vulnerable:

  1. Conectar la imagen ISO con el parche de seguridad de VMware en la unidad de CD-ROM de VMware vRealize Business for Cloud.
  2. A continuación, iniciar sesión en la interfaz VAMI usando las credenciales de administrador.
  3. Acceder a la pestaña “Update” desde la interfaz de usuario de VAMI.
  4. Del mismo modo, acceder a la sección “Settings” bajo la pestaña “Update”.
  5. Seleccionar la opción “Use CDROM Updates” y seleccionar la ruta donde se encuentre la imagen ISO. A continuación, pulsar “Save Settings”.
  6. Hacer clic sobre “Install Updates” bajo la pestaña “Status” para aplicar el parche de seguridad.

VMware recomienda realizar copias de seguridad e instantáneas antes de aplicar el parche de seguridad. Además, debido a la criticidad de la vulnerabilidad, recomiendan aplicarlo cuanto antes.

Más Información:

VMware – vRealize Business for Cloud 7.6 Security Build for VMSA-2021-0007 (83475):
https://kb.vmware.com/s/article/83475

TheRegister.com – ‘Unauthorized API’ in VMware cost management tool can be exploited to hijack appliances:
https://www.theregister.com/2021/05/06/unauthorised_api_vmware_vrealize/

BleepingComputer.com – VMware fixes critical RCE bug in vRealize Business for Cloud:
https://www.bleepingcomputer.com/news/security/vmware-fixes-critical-rce-bug-in-vrealize-business-for-cloud/?&web_view=true

La entrada ‘VMware vRealize Business for Cloud’ afectado por una vulnerabilidad de ejecución de código remota (RCE) se publicó primero en Una al Día.

Compartir