Vulnerabilidad en MAMP Pro 4.2 permite escalado de privilegios

El instalador de la aplicación no asegura los permisos los ficheros ejecutables, permitiendo su reemplazo para escalar privilegios

Se ha informado en las listas de correo de seclists de una vulnerabilidad en el instalador de MAMP Pro 4.2 que permite el escalado de privilegios en la máquina, pudiendo obtenerse así privilegios del sistema con cualquier usuario autenticado.

MAMP Pro, el software afectado, es un entorno de desarrollo web para Windows que incluye de serie un intérprete PHP, una base de datos MySQL y un servidor web Apache o Nginx para trabajar, similar a otras soluciones del mismo tipo como XAMPP o WAMP. Este tipo de paquetes es muy empleado por desarrolladores web que se inician en la programación en PHP.

Aunque sólo se ha comprobado la vulnerabilidad en la última versión del software, es probable que afecte también a versiones anteriores. No existe una actualización que solucione el problema, aunque corrigiendo los permisos de los servicios de forma manual evitaría el escalado de privilegios.

Estos servicios, ‘MAMPPRO’, ‘MAMPPRO-Apache’, ‘MAMPPRO-MySQL’, ’MAMPDNS’, ‘MAMPPRO-Memcached’, ‘emailrelay-service.exe’, y ‘MAMPPRO-NGINX’ se ejecutan todos con privilegios de sistema, aunque sus ejecutables pueden modificarse por cualquier usuario autenticado (‘NT AUTHORITYAuthenticated Users’), pudiendo escalarse privilegios con solo reemplazar el fichero y esperar que el servicio se ejecute.

Desde Hispasec se recomienda a los usuarios de MAMP corregir los permisos de forma manual a la espera de una versión que corrija el fallo. No se especifica en la fuente si la desarrolladora del software ha sido advertida del problema para su solución, al no existir un identificador CVE.

Más información:

MAMP PRO 4.2.0 Local Privilege Escalation:
https://seclists.org/fulldisclosure/2020/Jul/att-34/MAMP_PRO_4_2_0_Local_Privilege_Escalation.txt

Comparte en tus redes: